Mesh and collider do not match

The piece in the picture has a Mesh Collider but the Mesh and Collider do not match. The Mesh is here but it doesn’t match the Mesh Collider, what is the reason for this?

You have two ways to solve this issue.

First solution: very fast but resource intensive.

Because you have set the Mesh Collider to Convex the calculation won’t be precise and it will approximate the Collision of the object.

To make the Collisions precise remove the Mesh Collider you have put on the Model, inspect the Import Settings of the Model and tick Generate Colliders.

You will see a Non Convex Mesh Collider added to your Mesh. The Collisions are now precise!

Second solution: slower but optimized.

You need to create easier Shapes that will act as the Collision of your Model. Don’t apply the scale, position or rotation of the Shapes or Unity won’t be able to map the size of the Colliders correctly.

By doing this the workload on the Collision Calculations is much smaller.

NoMeshCollider