Mesh optimization in Particle System

Is it possible to turn off (in my case on Android devices) mesh optimization for Particle Systems that are using meshes as a particles? Is there a Unity’s setting that I can change in order to switch it off?

This is an example of properly rendered particle:
176016-001.png

And here I have a described problem:
176017-002.png