Mesh pop-in/cull with Blender animation.

Hi all.

So I have an issue I can’t seem to find a simple solution for. Using Unity 2019.2.4f1 and Blender 2.9. The object in question is a cockpit-like interface made up of multiple objects, some with multiple vertex groups, but all sharing the same armature.

Here’s the problem:
I have a scifi racing game, and in first person perspective you see gauges deploy when you start the scene. The problem is, if you headlook away from them, they pop out of existence before they leave the FoV. From experimenting, my best guess is that Unity is interpreting them as in their origin position before the animation moves them up. The only thing that seems to work is parenting an object in Blender directly to the bone of the armature, but this isn’t ideal if I’m trying to use objects with multiple vertex groups.

The initial setup I tried using in Blender was using only the modifier armature and assigning the rig which would link up with the vertex groups I assigned on the object. Keep in mind when you do this, no parent shows in the ‘Parent’ field under ‘Relations’. So I thought maybe that was the issue. When that didn’t work, I used Ctrl-P > Armature Deform. It created a relationship visible in the ‘Parent’ field, but also created an armature modifier and ultimately left me with the same pop-in. Lastly, I used Ctrl-P and assigned the objects directly to a bone of the armature which doesn’t go through an armature modifier, and did work. Problem is, I’d need to break out that object into several more to all assign to their respective bones and I’d rather not (think of breaking out and assigning a flight stick with all the hats, buttons, etc).

I’ve tried turning the camera culling off, but that does nothing, not that the object in question is set for culling anyway.
I’ve tried messing with the animation culling, but nothing.
No import settings did anything or were seemingly relevant.

I’m at a loss here. Any help would be immensely appreciated. If you guys think you need to see anything, let me know. Thanks.

Guess I need to answer my own question. Seems like the best solution I found is under the skinned mesh renderer settings: checking the “update when offscreen” option. This allows the object bounding box to follow the mesh. Unity - Manual: Skinned Mesh Renderer component

Hopefully someone else finds this useful.