Mesh renderer does not move with parent rigid body

I have, in my scene, a GameObject with attached 3 walls and a floor. I want these four objects to move with a rigidbody I assign to GameObject. When I do, only the colliders move with:

Before and after

What’s the correct way to make these mesh renderers move with the rigid body? They are children of the Parent GameObject (the one with the rigidbody).

I already tried attaching a rigidbody to the walls and making them kinematic, but no cigar.

Thanks for your time.

Turns out there is a checkbox marked “static” right up the top in the inspector. Sometimes you’ll turn this on to do things like baking lightmaps, but it you leave it on then the geometry wont move

I had this same exact problem. Turning off Static on the meshes that were moving fixed it.

Sorry this is not an answer, but I have the same behavior happening in my game, but only on iOS and OSX - PC is fine.

I have scripts to click-and-drag an object. When I drag the object the collider is moving correctly but the mesh stays in its original location… but only on OSX/iOS

Did you ever solve this problem?

and old post but I found turning off static batching in your project settings and reimporting did the trick.

Apply Root Motion was ticked for me.