Meshes not respecting Blender uv maps

I’ve made a simple cube in Blender with 2 uv maps (1 for the top and bottom and 1 for the sides) with 1 texture assigned to each of them. I’ve brought the mesh into blender, and see that the textures are being applied to the correct faces, but those textures are not respecting the uv map of the mesh (for example, the top and bottom are being filled by the texture, but it is the wrong portion of the texture). I’ve included a pic (note the black part) to give you some reference point.

In Blender:

In Unity:

Any idea what is going on here? Any response appreciated.

I sometimes get this issue. I just delete the object from the project view and re-import it.

This usually happens when I’ve updated the UV map in my 3D program and try re-importing the the fbx file by just replacing it which, for some reason, doesn’t update the UV map in Unity.
There’s probably a better way to solve this but I’m not too sure.

You might have a problem with your normals. Sometimes it try to do that on a cube.

I get this a lot and have found the only way I can correct them is to use External Materials (Legacy) option in the Materials Import Settings.

  • Click on your imported model in your

  • Select the materials tab and in
    Location - select “Use External
    Materials (Legacy)”.

  • Then you will have to import the
    texture file you used and assign it
    to a new material.

Name the material the same name that you called it in Blender and “BOSH” - It displays correctly. It’s a ballache as you would have to do this to every UV Mapped model that you import form Blender.