[Meta Quest 1 & 2] TryGetFeature(CommonUsages.deviceAcceleration) returns a zero Vector3

Hi,

With both Oculus Quest and Oculus Quest 2n in Unity 2021, 2022 (LTS versions), TryGetFeature(CommonUsages.deviceAcceleration) returns Vector3.zero. It is also the case with all acceleration features (rotationAngularAcceleration). This is the case for both handlers and for the helmet.

It works perfectly with Unity 2020 (with the same code), and whatever the version, it works for all other tested features (UserPresence, devicePosition, deviceVelocity, deviceOrientation, deviceAngularVelocity.

Please not that I don’t want at all to compute it from the deviceVelocity. The information I need is the acceleration measured by the handler accelerometer.

Has anybody encountered and solved this issue ? Is this a known bug ?

Thank you all

Renaud

If it worked in a previous version you can file a bug report. I've not used this in the past, so can't comment on it

Hi, did you solve this problem? I also met the same question. Thank you!