Miscellaneous File On All My Scripts

Hello, I know this question has been asked before but I’ve straight-up tried everything. Every time I open a new script in VS, it opens under a miscellaneous file and doesn’t allow intellisense. It’s super frustrating. I’m not that good at coding so I think I might just run with it for now so I can improve a bit but I want to fix this problem. I’ve tried making VS my default scriptwriter on Unity, VS doesn’t give me the option to rebuild the solution, I’ve reinstalled Unity, I’ve reinstalled VS and I tried both my SSD and my HHD… no dice.

The only way I get it to work is if I run a URP scene and open the camera move script then open another script. But once I delete the camera move script it goes back to opening miscellaneous files. Is there a fix I don’t know about? This started happening when I reset my PC and installed Windows 10 on my SSD which I doubt is a problem but it’s worth mentioning when it started. Also, I’m using Unity 2020.1 which is in beta. If your reading this post that means Unity 2019 doesn’t work either so that isn’t it. Should I get a new IDE…? If I don’t get this fixed I’m going to become a full-time Roblox dev and sell Robux on the black market…

Reinstalling VS by itself won’t work unless you also install Visual Studio Tools for Unity. In VS, go to Tools > Get Tools and Features, find Game Development with Unity and checked that it’s installed. If you’re lost you can refer to this guide: