Missing "Generate all .csproj files" in Unity 2020.3

Hi all,

Accordung to Unity’s 2020.3 external-tools documentation, there should exist an option to generate all .csproj files (the option is accessed by “preferences .> external tools”).

Unfortunately, the option disappeared when updating from Unity 2019.4 to Unity 2020.3 although the documentation lists it. Any idea where it went? Or how I can generate the .csproj from Unity?

Thanks, Scot.

@apellisscot Hi! If there is no “Regenerate project files” button, make sure that “Visual Studio Editor” package is enabled in Package manager (That worked for me):

Good luck!

Changing the External Script Editor to Visual Studio caused the options to appear for me.

I’m not sure what you’re seeing but for me, when I go to File → Preferences → External Tools, there is a Regenerate project files button. That’s the button that does it, if it’s missing for you, I’m not sure what’s going on. Hope you figure it out!

I had this same issue updating a project from 2019 to 2022. Basically it narrowed it down to the JsonDotNet asset’s DLLs ( Newtonsoft.Json.dll ). After removing that folder, the installed Visual Studio versions finally showed up in the dropdown. After selecting VS 2022, I closed the project, and put the folder back. That seems to have somehow reset something, as now the issue doesn’t return when the JsonDotNet asset is restored. Very odd. If you experience this issue, it may be one of your assets - more specially ones that have .Net DLLs that may get loaded. Might be causing a silent internal error and preventing other modules from working properly.


Under Ubuntu 22.04, I installed VSCodium instead of MS version and got the same issue.
I finally made a simlink of code to codium and this solved the issue when selecting the tool path:

sudo snap install codium
sudo ln -s codium /snap/bin/code

In my case, I had a new laptop and no IDE was selected. To generate .csproj files, go to Edit ->Preferences-> External Tools and select Rider(other IDEs should work too.).

If that is not enough, click Regenerate Project Files button (That button is visible only if you have an IDE selected.).