Missing Hidden/VideoDecode material when building through TeamCity

Hi,

I am attempting to run a build through TeamCity but am unable to play videos in the app it produces.

When playing a video through the Unity Video Player I get these error messages:

Could not find material Hidden/VideoDecode
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 803)

Could not find video decode shader pass YCbCr_TO_RGB1 in shader <not found>
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 863)

Could not find video decode shader pass YCbCrA_TO_RGBAFull in shader <not found>
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 863)

Could not find video decode shader pass YCbCrA_TO_RGBA in shader <not found>
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 863)

Could not find video decode shader pass Flip_RGBA_To_RGBA in shader <not found>
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 863)

Could not find video decode shader pass Flip_RGBASplit_To_RGBA in shader <not found>
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 863)

Could not find video decode shader pass Flip_SemiPlanarYCbCr_To_RGB1 in shader <not found>
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 863)

Could not find video decode shader pass Flip_SemiPlanarYCbCrA_To_RGBA in shader <not found>
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 863)

Could not find video decode shader pass Composite_RGBA_TO_RGBA in shader <not found>
 
(Filename: C:/buildslave/unity/build/Runtime/Video/Base/VideoYUV420Convert.cpp Line: 863)

Note that this only occurs if I build through TeamCity.

When building manually (through Unity) there is no issue with video playback.

I understand that TeamCity runs in a different environment but apart from that, I don’t understand why it cannot find a Unity internal material.

Thanks in advance.

Check your Graphic Settings and see “Always Included Shaders”.

[100044-スクリーンショット-2017-08-17-102801.png|100044]

Hey can anyone show me how to go to the settings like @karasusan did i cant find it