Missing Material in AssetBundle Prefab

Hey there,

I built an AssetBundle of a prefab. There are no problems with the main gameobject, but if I download that AssetBundle to instantiate the gameobject, within the child object "InvisibleCollider" the material is missing. I set all references in the inspector, and clicked on "Build AssetBundle From Selection - Track dependencies" and uploaded it. If I drag the prefab in my scene, it works very well, with all materials. I also tried to put the required files in the resources folder. (see picture) The picture contains the necessary info i think.

"Imageshack AssetBundle Fail Picture"

Any Ideas please? Greetings

Don’t know why, the AssetBundle is the same, but this problem is fixed now.
On instantiation it loads correct with the right material.

What was the solution? I am currently having this problem.

I have encountered the same problem too. And it was solved.
For next someone, I’ll write.
You should check if a shader is supported, or if graphics level in player setting of andoird. (etc OpenGL ES 1.*)