Missing Paths in Animation window only with specific child selected?

Hey guys,

So I’m working on putting some effects together using the Animator, and so far all has worked as I thought it would. But now I need to trigger a particle system to start at “x” point in the animation. So when having the parent object selected, I can access the properties of the particle system through the animator, but they don’t actually do anything. For example I can keyframe the emission property to be off, then on when I want it, but the system never plays. Upon some further inspection I’ve found that when I try and animate the particle system manually, using the record button in the animation window, suddenly all of my pre existing animation data turns yellow, and I get the “missing path” issue. But ONLY when I select my particle system obj. I assume this is why when I animate the system, nothing happens.


So far I’ve tried making a new prefab, to be sure all the 4 objects exist in the same one, and I’ve also tried to figure out how to rename the animation data to fix the missing paths, but to no avail yet! Anyone have any ideas/suggestions for things I should try?

Thanks in advance!

So her’s a quick follow up for those following this question. After fiddling around enough, I finally made the discovery that the particle system object had an Animator component on it somehow. I have absolutly no idea how it got there, that’s another mystery to solve, but it was also the culprit. Simply removing the Animator component from the particle system, and ensuring that only the parent object had and Animator component has fixed my issues!