Missing prefabs after downgrading from Unity 2018.2.0b2 to 2018.1.0f2

Hi I have been using the latest beta Unity 2018.2.0b2 however recently the official release of Unity 2018 came out so I installed the official release and opened my project but pretty much all of my prefabs are showing as missing. I tried a reimport of all assets but no luck
Is there anyway to fix this?


There’s a workaround.

  1. Install Unity 2018.2 (if possible in parallel to 2018.1)
  2. Duplicate your project and open it in 2018.2
  3. Your broken prefabs will look fine here. Create a new scene and drag those in the scene
  4. Break prefab instance of those prefabs
  5. Save the scene. (Serialization of prefabs and scenes is different)
  6. Copy the scene in the older version project.
  7. Open the scene in 2018.1, drag working prfabs and drop them on the broken ones in project folder.

Hope this helps.

Easy Workflow i have found:

1_expand all hierachy

2_break all prefabs

3_save scenes

4_open in older versión.

5_reimport all packages.(i always save hardwork Prefabs in packages).

You need to fix it the .prefab and .unity files
Solution here: Reddit - Dive into anything

Yes I was stupid I was hoping I could get a few extra fps by upgrading and also waned to try the new .net

I know sometimes that some references/prefabs would should as missing but literally 90% are, its ok if I use the beta again they all come back

Whats strange is I have “missing prefab” if I say delete an asset from the assets folder but the prefab shows again in a scene if I put it back. However this time all the assets are still there its just my scene cant see them.

How does one reference them again? thanks!

I’m working in a VR project and I made the transition from 2018.1.6 to 2018.2.5 a few days ago. The project broke and it was crashing when trying to load a new scene. Fortunately the fix from @phygitalmadhouse worked and I’ve only wasted 3 hours to recover from the transition. Unfortunately the android log of the device didn’t tell me a reason why it was crashing, so no upgrade to any new version of Unity for at least some months.

Good day.

You mean the reference in the ispector is mising?.

Then you need to reference them again…

I still dont understand why people modify Unity versions in the middle of a project… is obvious there will be problems…