Mixamo exported animations have rigs that are not in t-pose after importing to Unity. Renders Mixamo useless.

Hello,

When I export animations from Mixamo they come on a rig in FBX format. That rig is not in t-pose after importing to Unity. Instead it is in the pose of the first frame of the animation clip.

You can force t-pose in Unity. This will rotate the root transform of your rig and skew entire animation that happens relative to that transform.

Example. Let’s say you have a walk forward animation.
In the animation’s first frame (and imported rig pose) the root transform - hips are rotated by 30 degrees around up axis. You force the t-pose. You just rotated the hips by 30 degrees. Your animation will now play relative to that rotated transform.

What was meant to be walk forward animation now gets skewed into a wonky strafe animation.
Try applying root motion and start blending those skewed animations - grotesque results.

What am I doing wrong?

Thank you.

Solution:

In inspector for the animation clip fbx source file under Animation tab change setting: Root Transform Rotation → Based Upon (at Start) to Original. Now it “Keeps the rotation as it is authored in the source file”.