Mobile joystick is not working in unity5.6.1 only jump button works

I am trying to make a first person mobile game, it needs mobile joystick , some videos on youtube like link text just use the Standard Assets , I did the same way, but my game not working.

Here is what I did in unity5.6.1 :

  1. I create a new project , choose File>Build Setting>iOS and Edit>Project Setting>Editor>Device>iPhone.
  2. I create a ground for player, choose Create>3D Object>Plane and I tried other 3D object like Cube.
  3. I create a EventSystem, choose Create>UI>Event System.
  4. I drag FPSController from Standard Assets/Characters/FirstPersonCharacter/Prefabs to Hierarchy.
  5. I drag MobileSingleStickControl from Standard Assets/CrossPlatformInput/Prefabs to Hierarchy.

All steps are codeless .

Now , I have two button on screen, left one is Mobile joystick right one is jump.

In play mode I press the jump button and it works, but ** press the joystick button nothing happened ,even can’t drag the joystick.**

So, why only Mobile joystick doesn’t work?

Hey man, I had this same problem. I was using the FPS Controller (first person character) prefab from the standard Assets Library. Turns out if you are you are using that prefab, you need to disable “Lock Cursor” on the First Person Controller Script thats located on the FPS Controller prefab. This was driving me nuts and thats what finally worked. I hope this helps.
@usthis @nihaowa

Thanks Bro :slight_smile: working