Monodevelop Autocomplete/Intellisense and UnityScript.

Hey everyone.
I recently updated to 5.3.0f4, and suddenly Monodevelop lost the ability to use Autocomplete/Intellisense.
While I can live without this, it’s getting pretty frustrating.
I’ve read through several forums online and so far have tried:
Reinstalling Unity.
Deleting all root files and resyncing the project.
Manually setting the default compiler in Preferences>External Tools.
Changing the preferences inside Monodevelop itself.
Opening the .snl file through Monodevelop.

So far, nothing has worked. The only thing that’s changed is any C# scripts I have will now autocomplete, but nothing for my UnityScript scripts. Anyone know any alternatives.
Also, I’ve grown fond of Monodevelop, and would prefer not to have to switch to Visual Studio.

Well, it’s not exactly a solution, but reverting back to 5.2.4f1 seems to have solved it. Anyone come up with any other answers?

Same, somehow monodevelop is not autocompleting unity script. Tried the method on the forum but it doesn’t work. Anyone can help?