MonoDevelop AutoComplete not working

For some strange reason, my MonoDevelop AutoComplete is no longer working.
I am using Unity 3.4 on Mac OS X 1.07
I have the latest updates for MonoDevelop, and the Mono Framework.

I have reinstalled both, but I am still having no luck. I have also tried to sync with MonoDevelop (in Unity), but that does not seem to help either.

One thing that is happening which I think may be the cause, is an error I receive once I open a script from Unity, and MonoDevelop Opens.

The error reads "/Users/Kyle/Development/Unity Project/Thrill/Thrill.sln(10): Unsupported or unrecognized project : ‘/Users/Kyle/Development/Unity Project/Thrill/Assembly-UnityScript.unityproj’.

If someone could shed some light on how to fix this, I would be very pleased.

Thanks for your time,


Looks like you have vanilla Mono with no Unity stuff. Uninstall, then reinstall Mono from the Unity package.

I had this same problem using unity version 5 (with windows 10)… See my answer here on what others tried and what finally worked for me…

Hope it works for you too.

  • TonyTough