Monodevelop autocomplete on enter, not space.

Is there any way to get autocomplete to fill in text when I hit enter as opposed to space? As it is at the moment I will be trying to set up a for loop (for example) and when I type “i = 0” I end up with “if = 0”. I have found how to turn autocomplete off, but it is a feature I am used to from other IDE’s, and with this one change it would be great. Thanks!

You can enable “suggestion mode” in Edit->Toggle Completion Suggestion Mode.

In this mode, suggestions are only filled in if you press enter or tab.

Source: http://mjhutchinson.com/journal/2011/02/monodevelop_tips_suggestion_mode