MonoDevelop C# Assembly problem: UnityEngine does not exist in current context.

I don’t know for how long, but recently monodevelop stopped letting me create and edit C# scripts for UnityEngine.
If I open a perfectly functioning C# script i would be met by a script filled with red markings and out of context references such as;

  • UnityEngine
  • Monobehaviour
  • Everything Unity related really

I’ve googled alot and looked at several people having the same problem and solved it.

None of the solutions worked for me though.

Things I’ve tried so far to fix the problem:

PS: I reset unity inbetween all “fixes”

  • Check for errors in script
  • Change target framework to various .Net versions, Higher and lower
  • Check for script errors again
  • Create a brand new C# script
  • Delete all .proj and .sln files in project folder
  • Open script from Unity to rebuild Assembly
  • Delete userprefs for MonoDevelop
  • Delete .proj and .sln files again
  • Change built-in Editor back and forth from Visual Studio back to MonoDevelop

I’d like to keep using MonoDevelop in the future as I have a much better workflow in it than Visual Stuido.

So if anyone has some suggestions or some tips, I’d appreciate it.

Thanks for reading!

Install #Gtk for .NET from the link then restart unity and mono develop will work

Download link For #GTK