MonoDevelop Compile Error

So I have a test script, very very basic. It’s one variable that simply adds one every second and outputs it to the log.

The game can build just fine apparently but I’m getting an unusual error I’ve never experienced before. When I hit “Build” → “Build All” in MonoDevelop, I get 2 errors that say:

  1. Error Error: System.IO.FileNotFoundException: Could not find file ‘C:\Users\Kaze’. (Error: System.IO.FileNotFoundException) (Assembly-UnityScript-firstpass)

  2. Error File name: ‘C:\Users\Kaze’ (File name) (Assembly-UnityScript-firstpass)

I think part of the problem rests in MonoDevelop not understanding a space. My actual username on my computer is “Kaze Enji” and I think the space is throwing things off. Under the settings for project location in MonoDevelop though, the directory path is correct. You can’t change the username’s folder in Windows 7 without a reformat and changing my User Account name has no effect.

I purposefully screwed up the script to further test things and MonoDevelop is getting stuck on the aforementioned errors and will not tell me the other errors in the script.

Can anyone help?

Thanks,
-Kaze-

Have you tried creating a project in a directory that’s outside your users directory? i.e. “c:\ emp\” If this compiles fine then it sounds really like a bug and you should report it.

Sounds like others are having the same issue.

http://forum.unity3d.com/threads/98131-Unable-to-run-project-in-3.4

I’d report it as a bug - though this doesn’t help you solve the issue.

Just wanted to let anyone who’s interested know that Windows 7 will not allow a transfer like we’re attempting here. Updates to the OS that MS have done in recent months have disabled this transfer within the computer. It got to a point where I would’ve had to transfer my files and such off to an external drive then attempt to transfer them back on after creating this new account. I didn’t try that because by the time I got that far, I’d already purchased a new SSD to use as my primary drive. So during the reformat and reinstallation, I just created the account w/ no space…

I did report this as a bug and Unity said the fix should be in the 3.5. A friend of mine downloaded the 3.5 BETA and still no luck. I obviously haven’t checked because of my new username so I don’t know. But, hopefully this will be good news to some people out there.

Enjoy~
-Kaze-

I too had this problem and it was solved by changing my TMP and TEMP variables to a folder without a space in it. In Vista this is found under Control Panel > System > Advanced System Settings > Environment Variables.

Could be the same issue as this thread.