Monodevelop deleted my hierarchy/scene

I had my scene saved and tried to run a debug in Monodevelop it when it tried to open unity ut said it was already running, so I saved my scene and project an quit Unity and then tried running debug in monodevelop, when it started my hierarchy was empty and also my scene but all the procject files are there, but when I try to open the unity file with my scene it is still empty.

Any sugestions?

Generally, Unity and Mono for unity share a connection to share data between the applications. Avoid closing one and saving in the other, it’s possible that data was corrupted as a result.

If it happens again, submit a bug and try a fresh install.

Did you edit your scene while in playing mode? Every change made during playing mode is not saved.

Also if you want to debug using MonoDevelop and Unity is already running, you just have to “attach” the debugger to the running instance of Unity. So instead of clicking and the debug button, click and the other one called “Attach to Process”. Note that this also works with standalone player and webplayer in development build.