MonoDevelop fails to start after updating to Unity 5,3,4f1

Hello, I’ve got a problem that MonoDevelop won’t start when I updated the Unity’s version to 5.3.3f1. I’m currently using 5.3.4f1 and still got the same issues.

Here’s a screenshot of what I’m talking about.

I’ve tried different solutions like downloading the GTK and latest .NET Frameworks but none seems to work. I know I can just use Visual Studio but the file size is too big and I have a slow internet. I’m currently using Notepad++ as a temporary tool, but I don’t really like it as it doesn’t have that much features than MonoDevelop.

If anyone can help me out with this, that would be great!

I do not know the reason behind this, but every 10 to 15 builds I run will break my MonoDevelop app. I keep the gtk-sharp installer on my desktop for quick repairs.

Repair Process:

My dev box is a windows 10 and for the last few months this occurs way to frequently for me to believe that I am breaking the IDE.

Hopefully this helps.

Fix here Fix "monodevelop-unity failed to start" ! - YouTube