monodevelop not opening

Hi guys,

I am using unity free version & I am not able to open monodevelop. When I double click monodevelop or the c# file inside unity nothing happens(not even any error messages or pop-ups).I am using windows 8. Monodevelop is not even listed in task manager. Is this experiencing any compatibility problem or any driver issues ??

Also tried running compatibility troubleshooting & re-installed both unity & monodevelop. Nothing worked.

Go into into task manager, and kill any background processes related to Monodevelop. If you cannot see background processes press more details at the bottom left of the task manager, and they’ll show up. If that doesn’t do it you can also try sync Monodevelop project from the assets menu up top. Also, make sure Monodevelop is selected as your external script editor under edit >> preferences >> external tools. If those three options don’t fix the issue I usually just restart and when I get back up click sync Monodevelop before attempting to open a script.

I don’t know why you have such a strange problem mate, but I can suggest you to do something. Open your project in Unity and from the top-left menu choose Assets->Sync MonoDevelop Project. This should open MonoDevelop automatically. If that doesn’t help, you can try something else. Go to Edit->Preferences from the top-left menu and choose External tools. There you will see External Script Editor. The default is MonoDevelop (build-in). Click on the dropdown and click browse. Then navigate to (Unity installation directory)/MonoDevelop and choose the MonoDevelop.exe. Then Sync MonoDevelop Project again. I hope this helps. If this doesn’t help I don’t know anything else that can help you :frowning:

Have you tried searching the UA site yet? Others are having issues as well and there are a number of things users have done to solve this, hit up this and give some of them a try.

Hi,

I hope it’s not too late to respond and this message can still help you. I had the exact same issue and none of the other answers worked for me neither. What you need to do is to make sure you got the right .NET Framework and GTK# for .NET for your monodevelop. You should install the latest monodevelop version and update .NET Framework and GTK# for .NET from here: Download | MonoDevelop

open monodevelop, the open the file you want to edit from it.

Hi, I once met this problem. Some anti-virus programs delete Monodevelop without asking.
For me it was AVG. I deleted AVG then.

in my case it worked to download and insltall GTK# for .NET from Redirecting…

Open MonoDevelop and open the existing .sln file from your Unity-Project-Folder. it works.

Unity replaced mono develop with Visual studio.
Here is some more details on this