MonoDevelop not starting even though all assemblies installed, still not answered!

It started when I updated Unity to 5.4.3. When I try to open a script or open Mono from shortcut or even from the EXE, it says MonoDevelop-Unity failed to start. Some of the assemblies required to run MonoDevelop-Unity (for example, GTK#) may not be installed correctly. Download page, blah blah blah. I redownloaded GTK# and .NET SEVERAL TIMES and it still didn’t work, same error message. Anyone have this problem or know what’s going on? Please help!
-EDIT- Could it be because it’s trying to draw assets from Unity 5.3.5 even though I updated Unity? If so, how do I fix this?
-EDIT 2-
Here is an image:[82899-capture8.png |82899]

-EDIT 3- I’m running Unity and Mono off a USB. Don’t think that has anything to do with it, but just in case…

-EDIT 4- It’s a problem with .NET. The installer for .NET says it’s already installed, but I checked and it’s not.

Try the following

  1. First of install the latest version of .net from the official Microsoft website. Then install it and rerun Unity.
  2. If you are still having problems then download GTK# for .net from here.

Can you show us the script you’re trying to use?