MonoDevelop not working since Unity 4.1!

I Had Unity 4.0.x, then tried to update to 4.1.x, suddenly MonoDevelop stopped working. It just doesn’t open and brings a very weird window error.

Then I reverted back to Unity 4.0.0, eventually updated to Unity 4.0.1, all without issues… Now Unity 4.2 was released and I finally decided to try and update. Same issue.

What’s going on Unity Team? Why isn’t this solved yet? How could you even let this to happen?!

As sonicviz mentioned:

At the very bottom of Unity 4.2 release notes:
MonoDevelop may fail to start correctly on Windows if an old version of Gtk# is installed on the system. Please uninstall this version, and install a newer one if still needed.

GTK# has been the problem, and uninstalling it has been the “solution”, at least since Unity 4.1.4.

In my experience, updating GTK# to latest version (2.12.10) wasn’t good enough. But uninstalling it was an instant fix.

P.S.: Really, I just wanted to feed unityAnswers here. Did I mentioned already I hate forums?