MonoDevelop stopped working after Update.

I just updated Unity to version 4.1.4 and it works fine but when I try to open MonoDevelop I get a white screen with two white message boxes that have no text in them. Is this a problem with the update or should I just reinstall Unity?

Posted by Tak Unity Developer
Posted: 05:59 PM 28 Minutes Ago
“Hm, looks like an oops with our automated build environment.
Dropping http://files.unity3d.com/levi/MonoDevelop.exe.config into Unity/MonoDevelop/bin/ (next to MonoDevelop.exe ) should allow you to launch MD as usual.”

It worked for me, accept this answer if it also works for you

** This is incase the above solution does not fix your mono develop problem **

I had the same problem and followed the link but it did not work. MonoDevelop broke after intalling Unity 4.2, running the editor, closing the editor, ran the editor again, synced my project and it opened MonoDevelop. But MD threw the same exception as above and closed.

I had to grab the latest mono.cairo.dll (file size is 54k) and copy it over the previous version in Unity/MonoDevelop/bin/. Works fine now.

I have the same problem.
System.IO.FileLoadException: Could not load file or assembly ‘Mono.Cairo, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756’ or one of its dependencies. The located assembly’s manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

File name: 'Mono.Cairo, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756'

   at MonoDevelop.Components.Docking.ShadedContainer.DrawBackground(Widget w, Rectangle allocation)

   at MonoDevelop.Components.DNotebook.OnExposeEvent(EventExpose evnt) in c:\BuildAgent\work\f07246b5212f7be4\monodevelop\main\src\core\MonoDevelop.Ide\MonoDevelop.Ide.Gui\DefaultWorkbench.cs:line 1379

   at Gtk.Widget.exposeevent_cb(IntPtr widget, IntPtr evnt)



WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Also, the Monodevelop process will often still run after you shut down Unity and open it back up. That is why you may experience it working again when you restart your computer. Just hit CTRL+ALT+DEL or run taskmgr. Hit the processes tab and kill the process. (if you really wanna be smooth about it, hit windowkey, type cmd, in cmd promt, type “kill /f /im monodevelop.exe”) Anyway, just kill the proc bro.