MonoDevelop Strange Behaviour

Hi there,

I am using Unity 4.5, and have found that occasionally my keyboard shortcuts will stop working. I seem to be able to trigger it by opening the preferences, but sometimes it occurs randomly.

For example, after opening my preferences, ‘Cmd + A’ will do a random action which is either ‘delete the current line’, ‘open file’ or ‘change window’. Other times ‘Cmd + S’ will paste something on my clipboard.

I tried uninstalling Unity entirely, as well as MonoDevelop, and installed a re-downloaded version from the Unity site. As well as deleting the hidden MonoDevelop preferences folder in Library. But the issues are still there.

Any help would be excellent!

I have had this happen a lot to me, usually once ever other day. The best solution I found was to quit monodevelop, then reopen it. I have tried to research what is causing it but I had no luck. The funny thing it is usually ‘Cmd+A’ for me as well that is the issue.

I have the same issue with Unity 4.6.1f1 and Osx Mavericks
command + A sometimes opens preferences or minimizes the window

Probobly install Microsoft Visual Studio?
Though that is pretty heavy. If you have space, visual studio is alot more superior than monodevelop.
Then check on tutorials on how to switch coding programs on unity.