Monodevelop-Unity on OSX still requires admin rights to run.

This is something that’s been out there for a little while. Monodevelop-Unity(the altered version of Monodevelop that comes with Unity) seems to assume that you (the developer) has admin/superuser rights on the machine. I only give super-cow abilities to an admin account for various security reasons. In this environment Monodevelop-Unity will not launch correctly due to permission errors. It looks like it has to reinstall fonts or something every time the thing loads. Who knows. It seems wrong to have to be super user to run a development IDE. Anyone else having this problem on Mac?

You don’t have to have SuperUser rights access in order to run Unity. Just make sure that when you install the program if you are using different User accounts that the one that you are using is the Admin. I ran into this issue before with projects and user authorization when I switched between a couple of the accounts I have on my Mac (OSX 10.6.8)

We were able get Mono working for restricted users with a narrower granting of privileges

Right click and Show package content on
Open Contents folder and right click on Mono.framework
Select Show info on this folder
click on the padlock and authenticate with an admin-account
Change the setting for Everyone to Read and write
Click the wheel > Use on included objects

Thanks, schooltoons, for your solution of opening up the permissions on the Mono.framework package within MonoDevelop. That fixed my problem as well, which crops up now and again whenever I update or reinstall Unity (I’m currently using Unity 4.5.2 on an iMac).

Incidentally, for those who prefer shell scripts, here’s the one-line equivalent to the permissions change you suggest. This opens up permissions for admins as well as regular users to be read+write. Just be sure to be logged in as admin when you run this, as you can’t run ‘sudo’ with restricted privileges.

My hope is that someone at Unity3D will spot this thread and add this shell command to their installer so we won’t have to do it ourselves by hand!!

admin$ sudo chmod -R a=rw+X /Applications/Unity/

Regarding MarcinK’s earlier comment, when you copy an app into your user space, you’re changing ownership of all folders and files to yourself. When you •move• it (not copy it) back into /Applications (which requires an admin authentication) then that ownership is retained. Other users of your system will still see the same MonoDevelop problems, so it’s a better solution to open up the public privileges as schooltoons & I have suggested (his solution via the Finder GUI and mine via Terminal).

Have fun!!

What worked for me is copying into a user space, deleting the original, launching it from user space, quitting, than copying it back to /Applications/Unity and deleting the user space copy.

I have not investigated why this worked (I have couple theories), but MonoDevelop now works for me.