motorola xoom

Is there going to an update for an xoom tablet soon

What do you mean? I’ve been using Unity 3.3 on Xoom just fine.

I have tried to load 3.3 and tells me cannot load file?

I am also having problems running Unity programs on Motorola Xoom. I deploy APK file and run the app, I see the Unity splash screen, and then the program silently crashes and I see the operating system again. Some people suggested setting the player settings to OpenGlES 2.0. I tried it, but it doesn’t fix the problem. I also tried switching to another application and then back while the splash screen is loading, which is what other suggested as well, but that doesn’t work either. Is there any patch or anything to get Unity working on Xoom correctly? I purchased Xoom mainly for my Unity projects. It looks like I made a big mistake :(. Thank you.

I am not into any specific projects, I just want to run my NASCAR race view on my xoom and it wants me to install the basic utility…and nothing

I’ve had no problem with Xoom. Have you tried running adb to dump what’s going on on the device itself? If you don’t know about it, it’s like the console window in the editor. You can see Debug.Log statements there. You may have to pepper your code with those to track the progress and narrow down what’s crashing. If that doesn’t help, you need to start shutting off scripts and try til it works, to narrow that down. If that doesn’t help, you need to start turning off game objects/shaders/etc until it works, to narrow it down. Eventually it will work. Then add back the last thing you removed until it breaks. That will tell you what the troublesome component is.