MovieTexture.duration is -1

I am currently using a MovieTexture in a current project, but when I want to get the duration of the video, I get -1. I know that I have to start the video before I get the duration (which is incredibly annoying and a bit stupid), but the duration is still not there. I even tried to wait a frame after calling Play() or waiting for MovieTexture.isReadyToPlay, without an change.

I need the duration, because I have to do stuff when the movie is finished. I do NOT want to query if the video is playing.

The file is a ogg file, not converted by Unity/Quicktime.

I have found a couple of old threads, questions and bug reports on that topic, but none of them go beyond suggestiong to call MovieTexture.Play() first.

Does anyone here have any suggestions towards a solution?

I’m having the same exact problem with the same exact setup. Nothing seems to be working and I’m making an FMV game so it’s extremely obnoxious to not have any way to dynamically figure out the length of a current video clip outside of keeping a text file that needs constant updating.