MSVSC2013: failed to find SLN File

I have this working for my current main project, though i’ve no idea how i managed it. But i get the following error on attempting to open scripts in any newly created project:

Microsoft Visual Studio

The following files were specified on the command line:

E:\Projects\Testing Ground\($File)\UnityVS.($File).sln

These files could not be found and will not be loaded.


I’m trying to open them via doubleclicking the script asset within unity. Things are supposed to be all setup to go.
what’s wrong here?

You must import Visualstudio 2013 tools .unitypackage in your new project.
Then it works in my projects!

Have you tried to use the Visual Studio menu in Unity?

  • Create a new project in unity.
  • in Unity: Menu Visual Studio Tools/Generate Project Files
  • in Unity: Menu Visual Studio Tools/Open in Visual Studio

works for me.

I encountered this error after upgrading my project to Unity 2018.1.0 beta. Hopefully this can help someone:

I was able to re-generate the .sln files by right-clicking a .cs file in the project view and selecting “Reimport”. Unity then recompiled the project and generated the .sln files.

I had the same issue when creating a new project with 2018.1.0f2.

In Unity go to Edit>Preferences>External Tools

Switch External Script Editor from ‘Visual Studio 2015’ to ‘Visual Studio 2017’.

Not sure why 2015 was in there as an option but this solved it for me.