Multiple EvenetSystems in Scene - only have 1 after searching though

So i changed a scene and carried my GameManager object over using dontDestroyOnLoad which i assume had an extra EventSystem, it stopped my UI from working in the new scene. So i tried deleting the EventSystem from the new scene but my UI still wouldn’t work. So i added back my EventSystem for the scene and then deleted the GameManager that i carried over since i don’t need it after obtaining the initial info i carried it over for.

My UI still doesn’t work after changing the scene, even though i delete the extra EventSystem, is there a way to fix this somehow? looking for any options, i’ve been searching for the same problem from other users but nothing has worked.

From what i can see it’s definitely something to do with the DontDestroyOnLoad, even though im deleting it after it gets transferred, my UI doesn’t work, any help is appreciated.

You don’t want to delete the EventSystem at runtime. Instead, try removing the extra EventSystem objects in your subsequent scenes (like you did at first, but not in play mode), and have the EventSystem from the original scene part of DontDestroyOnLoad.