Muse texture and 2023.3 alpha?

Now muse is a paid sub, i signed up, and I primarily am working in 2023.3 (the nearest to the next lts i can get as my projects that young in cycle) and i noticed muse.texture loads 0.41 in 2023.3 and then doesnt work… (401 not authorised) and upgrading to 1.0.0 as it knows it can, then nothing… absolutely nothing not even a window

any ideas?

Hi @bugfinders,
Can you try to update Muse Texture to 1.0.0-pre.2? Do you have any error in the console? If there is no error, and there is no Muse menu/window, can you try to delete the project Library?

Sorry i didnt enter the -pre.2 and so no, no it didnt. I deleted all the muse portions from the project library as theres a whole ton of other stuff not really in the mood for it to reinstall… In fact, I deleted all muse stuff from my HD (i know where unity likes to hide things) to try stopping it using 0.41 and nope it was insistant that this was the version of choice… but no upgrading to pre-2 did not help as thats what i was on.

There is currently a bug where the package manager thinks that 0.4.1 is the latest version when adding a package by name. That version is deprecated. The current version is 1.0.0-pre.2
I understand that you don’t want to delete the whole Library folder as it takes time to reimport everything. Can you try to delete only the Muse packages from it? They should be located under Library/PackageCache/com.unity.muse.texture and also Library/PackageCache/com.unity.muse.common
I hope it works and that you can see the Muse menu item. If it does not work, can you share your editor log with me? You can send me a private message.

I feel i am repeating myself. as i already confirmed I did this in my last post I will send you an editor log

I received your editor log :slight_smile: Thank you for adding screenshots, it helped me understand the problem better.
I was able to repro the issue.

Here are the steps I did to make the Muse menu enabled again

  1. Open the package manager
  2. Remove Muse Texture
  3. Install Muse Texture following those steps
    3a. Click on the + button and choose “Install package by name…”
    3b. In the fields, in the name, enter com.unity.muse.texture and in the version, enter 1.0.0-pre.2 directly.
    3c. Click on Install

image

There is also a bug where when you click on an old Muse Asset (from 0.4.1) after updating the package, it makes Unity crash. Try deleting it with your file system instead, or delete it after closing and reopening Unity.

I’m sorry for the inconvenience. I hope it works!

ok. i will try, but im rapidly losing faith… what with behavior trees not working for webgl, i only make for webgl. i liked the muse chat, but the textures isnt really floating my boat that well, i mean ask it for a flint stone wall, you get either sand stone, or general rocks, cobbles cable back as a pile of rocks by the time you manage to pursuade it otherwise you’ve blown a lot of tokens somehow. 3k aint going to go far if its ide of making “cobbles” takes near on 200 tokens to generate a few texutres that clearly arent cobbles.

Thank you for your feedback, it’s really appreciated. I will share it with the team :slight_smile:

flint stone walls look like → ask muse for flint stone wall :smiley:

I just tried it, and I see what you mean. I got a bunch of rocks.
It’s not ideal but can you try this workflow?

  1. Take a screenshot of the texture you would like, ideally 512x512 (or smaller), ideally a square and save it on your computer.
  2. Drag and drop it in the Input Image - Color or click the Import button.
  3. You might need to play with the Strength, something around 55 might do the job.
  4. Write flint stone wall into the prompt.
  5. Click Generate.
  6. Click on the Refine button
  7. Click on the Paint button in Refine mode
  8. Paint a mask on the edges. (It’s to try to make the Texture seamless, sometimes with reference images, it does not give good results)
  9. Enter the same prompt flint stone wall and click on Generate
  10. You can click on the Material Preview button or right click and select View as PBR Material
  11. In the PBR preview, you can select the plane instead of the sphere and add some tilling to see if the seamless worked.
  12. You can also upscale the texture.

While Muse Texture is in early access, you can go over the 3000 points :slight_smile:

1 Like

thanks, so in short, all it really did was make it tileable… but it turned out pretty good with a few pokes, but again, it didnt take much to chew through points - those points dont seem to be like 4 for a set of 4 images etc, its not entirely clear what a point covers, or the cost of various things

oh and PS thanks yes, forcefully installing 1.0.0-pre.2 did make it work - shame when you consider upgrading should do the same

1 Like

Hi @bugfinders ,

I’m technically on my holiday break but I just wanted to let you know the Behavior team is looking into the WebGL issue. @LauraRantonen is currently looking into it and should post an update soon. I’m sorry for the rocky start! :confused:

1 Like