My builds are possessed (runs without data folder, runs a non-existant scene)

Simply put, my builds run perfectly when I double click to run them, which for most people wouldn’t be an issue, but when I decide to run the build with my secondary gpu, it runs an old scene that doesn’t even exist within Unity anymore.

I thought there was a conflicting file in the data folder of the build, so I deleted files, yet strangely the game was still running perfectly. I completely deleted the data folder altogether and it still ran that one scene, complete with all it’s assets, music and data. The exe is literally 20 mb, and there’s no way it has the assets stored in that amount of space, so it’s literally pulling data out of the air.

As you can imagine this is kind of annoying as I cannot build any other scene other than that one corrupted one and I don’t know what I should do. I’ve been working for months on this project and I simply refuse to let all my hard work go to waste.

Any answers or suggestions are greatly appreciated!

Here’s a video explaining what I mean

I tried updating and reinstalling unity with no luck, leading me to believe that it was an error with the build settings in the project itself. After exporting all of the assets into a package and making a new project and importing the package again, everything worked.

What might have happened was that I tried to remove the list of inactive scenes from the build settings by pressing the delete key and doing that might have caused an error. So if this ever happens to everyone, this is a workaround to fixing the problem. You’ll need to reset all of your tags and layers, but afterwards, everything will work as planned!