My camera changes/hides the terrain?

Hey all,

For some reason, whenever I turn the main first person controller camera, the edge of my terrain seemingly disappears. It was all working fine before adding the camera. I’m fairy new to Unity and still learning and I’ve tried Googling this but nothing has come up at all. Could anyone help with this? I’ve attached screenshots below!

Camera settings:

Field of View: 60
Clipping Near: 0.1
Clipping Far: 10000
I changed these settings from the preset just to see if it changed anything but no luck so far!

Assuming your terrain is over 7 square km, try to increase the Clipping Planes > Far value (currently 10 km)

1km = 1000 m = 1000 unity units

From wikipedia:
Clipping planes are used in 3D computer graphics in order to prevent the renderer from calculating surfaces at an extreme distance from the viewer. The plane is perpendicular to the camera, a set distance away (the threshold), and occupies the entire viewport. Used in real-time rendering, clipping planes can help preserve processing for objects within clear sight.