My character is really jumpy/laggy

Screen capture - e145a21952eb31d2f21e26a68e27ac69 - Gyazo Here is a low frame rate albeit fairly depictive gif, it’s much more jumpy running live and if necessary I can upload to my server so you can play it and see what I mean, I am just using this game to learn but this really jumpiness is an annoyance that I can’t solve…

Anyone have any idea? My movement is pretty much the script from the 2D example, its walking on top of a box collider of course, and has its own box collider and a ground check.

First of all test if this works:

Go into the project settings (or the actual code) and remove the gravity, also make your character be above the ground and try moving. If he moves smoothly it means that the collision is getting “stuck” on the ground.

That is why many people add a “skin” variable to their collision detection scripts, usually something like 0.01f so there’s that small gap between the player and the ground.

That is my guess on why it’s like that

If you have may animators, or animators that involves many objects, you may try setting “Culling Mode” of such animators to “Based on Renderers” instead of “Always”. Just for trying anything else…