My performance is a lot better than expected.

This is my first every project so i think i’m missing something but just wanted to understand why my vert and tri count is so low.
The model is around 4k faces and 5k verts in Blender and on import to Unity it has 14k verts and 5k tris, all of that is perfectly fine, however, I’ve laid each model in a 8 x 8 grid so there is now 64 of these objects should there not be a higher tri and vert count?

There is no LOD’s in place yet and during gameplay the vert and tri count stay stable no matter where the player is and how much of the scene they see.

Explanation on this would be awesome as i said just starting out on my Unity journey so i know there is an easy answer there i’m not getting but i imagine the answer will help me build out the rest of the game, thanks alot!

For the materials using by the Prefab, you may try to enable GPU instancing.

Quote from documentation:
Use GPU Instancing to draw (or render) multiple copies of the same Mesh at once, using a small number of draw calls. This is useful for drawing objects such as buildings, trees, grass, or other things that appear repeatedly in a Scene
If it still doesn’t improve a bit, better use Profiler to check the performance and see which part drain the resources.