My PNG gets distorted and isn't transparent when made into a material.

So basically I want to use a transparent PNG as a texture for a material. But I can’t get the material to be transparent. I’ve tried using “Alpha is transparency”, and it distorts it to look really weird. I’ve also tried turning it off, which doesn’t distort it, but also just doesn’t make it transparent.

The texture with “Alpha is Transparency”:

Without that option selected, the face renders with a white background where the alpha layer would be, though it does so without distorting the face. Still, I need the alpha layer to be transparent on the character.

Here is the material:

Basically, why is it distorted and not transparent. And how would I fix that?

Yo, that’s because your material rendering mode is set to “Opaque” which ignores the alpha channel. Just set it to either “Fade” or “Transparent” and you won’t even need to set “Alpha is transparency” on your texture. Judging by your texture you might also want to set it to “Cutout” mode.