My scene is empty

Hello, I've just started with unity. I like it very much but I have one problem I cant see anything in the scene. If I create for example a terrain I can see it in the game window but not in the scene.A screen : On the screen I did focus on the terrain with the F key. My rig: Processor:

Intel(R) Core™2 Quad CPU Q8200 @ 2.33GHz (4 CPUs), ~2.3GHz

4096MB RAM
Hard Drive:

737 GB
Video Card:

NVIDIA GeForce 9800 GTX+

Operating System:

Windows 7 Ultimate

I hope someone can help me.

I Don’t know if this is way to late, but for me the problem is solved by right-clicking the “game” tab, then “add tab” then “scene” poof!

Click on the terrain in the hierarchy and press 'F'. This will focus and zoom on the terrain in your scene window. Make sure you turn you view a little, or you might end up being precisely on the side of your terrain, and if it's flat, you still won't see it! :)

But try different orientations as well.

There is a Layer Icon in top left, Make sure “Default” is enabled.
I’ts worked for me.

I had an issue where the terrain would not display at all. After a few minutes of tinkering, I finally found the answer in the following screenshot. Hopefully this helps someone =)

In the top right under layers dropdown, mine was default to “nothing”, i clicked “everything” and everything started showing as expected.


Hey guys,

New user here and I know this is an old thread but I found it searching and maybe the next person who does will benefit:

I was having the same problem as described in this and other threads: an all gray viewport, no grid, geometry invisible in scene unless selected in the hierarchy. Position and scale were 0,0,0 and 1,1,1 and applying a texture or creating a light made no difference.

There were two problems, both simple but frustrating for a noob like me regardless:

  1. missing grid: It turns out there IS a grid toggle; it’s the background button between the light toggle and the sound toggle, just above the viewport. Unity could really use a “view” drop down so these options are in locations similar to Max and Maya, even if redundant. Mouseover tags would be nice too.

2)Objects not displaying: despite switching numerous scenes and projects and re-installing Unity twice, my UI settings didn’t reset and some layers stayed turned off (presumably from my messing with them in the tutorials), including the default later! You can create objects on the default layer while it’s turned off, thus making your objects invsible in scene view but visible in the game view.

Short answer: make sure you don’t have anything on hidden layers!

Feature request: It’d be fantastic if “revert factory settings” would also revert to default visibility settings, including layers and within viewports!

do you guys have a camera in your scene if yes then make sure some thing is displayed in camera preview if not then go to gameobjects->create other->camera and adjust it accordingly let me know if it solves the problem

hello everybody none of the methods work for me please help