My Scene is Invisible

Guys I really need help b/c this is pissing me off. I spent 9+ hours coding my FPS. I had to go pray with my family for like 10 mins, came back and I couldnt see the scene tab or the game tab. So I set everything back to default. I have my tabs and when I press play on the game tab everything works perfectly. But when I click the scene tab all my objects are invisible. The ground,my player, enemies, markets, coins, teleportation pads are all invisible. Please help me! I tried closing the project and restarting unity and opening a new project but no matter what the things in my scene are invsible. All I can see are the meshes if I click on them. Im really frustrated.
Should`ve gone with UDK :stuck_out_tongue:

This is late – but I’m answering in case others have the same issue…

Another thing to try is the “Layers” tab in the upper right hand corner of Unity. This is a layers view tab. It’s used to check and uncheck the layers that are visible in the scene interface. The “Default” layer usually needs to be checked. In some tutorials, other layers are critical.

Please note that the Layers tab we’re using here is different than the one that’s used to assign assets to layers. We’re NOT using the layers button in the Inspector.

Hope this helps. I had the same issue today.

it’s old post but someone other will need the answer,look in the inspector in the Mesh Filter…there is missing mesh,find the mesh and objects will appear again visible!
i had the same problem and found the solution.