My Unity is crashing 90% of the time when opening a project (SOLVED)

EDIT: SOLVED!

Someone on reddit had said

"I read your editor log and there’s absolutely no hint of what is going on. Everything looks normal. Then it just shuts down.

It’s as if you opened Unity and then immediately hit cmd-q"

It turns out this was exactly what was happening! I had downloaded an app called swift quit (https://swiftquit.com) which quits an app when you press the red close button on a window (like it works in windows).

For some reason, this app was simulating a cmd+q every time unity opened… sooo strange why it’d do that cos obviously I didn’t click on the close button or anything else.

I’ve added unity as an exception and it works. Thank god


Hi guys, just wondering if anyone has any idea what could be the issue here.

I’m on a Macbook M1 Air 8gb. MacOS Sonoma 14.3.1

90% of the time, my projects crash when openiing. Most of the time the Unity GUI hasn’t loaded yet and it crashes, sometimes it loads the GUI but in literally 1 second, unity crashes (ie completely closes). Once it’s open, it remains stable. But if I close it and reopen it, it crashes again.

We are using 2022.3.19f1 and the other dev on my team says it works on his windows machine just fine.

Here is everything I’ve tried. Every step along the way I tried and the projects continued to crash:

  • I deleted and cloned the repo from scratch to be safe.
  • To rule out that it isn’t my project, I created a new 3D URP Project, and still have the same issue on the fresh new project. Sometimes 2 different fresh projects had one working, the other not. Then they’d switch.
  • Deleted unity hub and opened the project just with unity itself
  • Reinstalled unity hub
  • Deleted my project settings, temp and user settings folders in my project’s folder as per a suggestion I saw on a forum somewhere.
  • Removed license inside unity hub and added it again (license still says it was activated 2021 so idk if I did the right thing?)
  • To rule out that my 8gb RAM isn’t the issue, I checked activity monitor and it never goes above 6.5gb and has no swap memory being used.
  • Tried the latest editor version 2023.2.9f1. At first it seemed to solve the issue, the projects consistently opened. After restarting the mac though, they went back to crashing most of the time.

Here are my logs: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free