MYSTERY: no iPhone shadows, example project...

Here’s an iOS project. As you can see in the editor, it has shadows.

When you build it to iOS … no shadows!!


any ideas??

you will need iOSPro to test this, as only iOSPro has shadows.

As an everyday matter I create new projects with shadows that work fine on iOS. But for some reason they don’t work in this project. What the heck could it be here in this project?

As I mentioned in another question: I suspect there could be an obscure Unity bug where, if you launch a project (default platform == PC) and then import, and only later change platforms … it could be the shadows do not work in that situation. This is just a guess though.

No matter what I do, I cannot make the attached project give shadows on iOS!!

USEFUL TIP: to save you time. You do not actually have to build through to an iPad to test it. Just click “Build” in Unity. Keep your eye on the “game” screen. While building, you will see for a few seconds a preview of each scene as it will actually be on the device.

Weird huh?

Any ideas?

Your quality setting is set to zero, so you get no shadows.