NavMesh Components for 2017.4.9f1

I could really use some help please! I am trying to add a NavMesh to some stairs that lead up to a house (because the automatic bake doesn’t catch the stairs) and from what I’ve read I need to use a NavMesh Surface, but when I go to the versions (Releases · Unity-Technologies/NavMeshComponents · GitHub) I have tried the one for 2017.2.0f1 and the latest but both give the “compiling scripts” at 50% forever error when I try to import them and restart.

I am really new to Unity is anybody able to tell me where I can get a version of NavMesh Components that is compatible with 2017.4.9f1 please? Or know if I can add NavMesh to the stairs somehow else?

According to the repository description:
“Please use the branch matching the version of your Unity editor: master for the latest released version, 2018.3, 2018.2, 2018.1, 2017.2 for up to 2017.4-LTS, 2017.1, 5.6.”

So the 2017.2 version should work for 2017.4 versions. If it’s not compiling, there’s something else in your project interfering.