NavMesh not baking underneath 'overhead' sections of mesh, for one particular mesh only.

So in my game we have multiple floors through which the AI walk. I recently imported these blend files for each floor and set them up to bake the NavMesh for each. The one for the ‘Upper’ floors baked fine, as you can see below.
alt text

When I setup the next ‘Lower’ floors in the exact same fashion, the resulting NavMesh is broken up into ‘chunks’ (as you can see in the image below), as it seems unable to bake underneath the arches for this mesh - despite having no issues for the previous ‘Upper’ floor.

When we were prototyping with another mesh, we ran into a similar result with the NavMesh that was fixed by simply increasing the scale of the model by about 0.5 units. We have tried that for in this case, and it has had no effect.

I’m pretty stumped as to what I could have missed here, we have even looked into the setup of the mesh itself and tried various different settings - with no successful results. Its as if the mesh is detecting a mesh from the beam to the ground despite there being no mesh there.
We are currently using Unity 2018.3.11f1 - its the only version of Unity we have used in our development cycle for this project so far.

Update - We have discovered that changing the baked agent height size in the NavMesh settings fixes this issue for this mesh. Oddly though, raising the height of the archways (so that we can keep the height as necessary) does not fix the issue.