Navmeshagents slowing down when going around edges


Im using a navmeshagent to move around some transforms at the speed of 10 and I noticed that when they’re going around edges they slow down by a lot. My transforms aren’t using any colliders or rigidbodies, only the navmeshagent which has a really tiny radius.

Is there any way to fix(?)/change this?

One more thing, does the navmeshagent radius affect the pathfinding/avoidance at all ? I made it huge but the transform doesn’t react to its size. Now Im making it look better by editing the options in the navigation window, but this isn’t what I want as some paths become unpassable.

Thank you for your time.

This stopped happening after I built a level in Maya and imported it in unity. It now works great, maybe it’s because the walls are way thinner. But it works great now so I won’t question it (^.^).