Near plane adjustment in Scene View

How can I adjust the near plane clipping in Scene View? It seems the near plane is automatically adjusted by the Editor in the Scene View, but sometimes it becomes too far, clipping out the objects I want to manipulate, or too near, leaving nearest objects or terrain unclipped in front of the things I need to reach. The same thing occurs with the right button pivot point, sometimes automatically adjusted too far or too near. If there’s no adjustment way already defined in current version, I suggest in future versions something like CTRL, SHIFT or ALT plus the mouse wheel to do these adjustments in the Scene View.

Select an object and press f (while focus is on scene view) to point you camera at it and put the focus point on that object. This will adjust clipping planes to suit the object’s size.

Had the exact same problem and figured out the Scene View camera is zoomed out too far. The fix. Zoom out, then use the WASD keys(or however else you want to move the camera without zooming) to move
the camera back toward what you want to be looking at, toward the thing(s) that were previously being clipped out of view. You’ll more than likely need to do this multiple times before the clipping is adjusted
to the desired value.

Hold right mouse button, then press W or S, to increase or decrease clipping value.

I think I found the answer to this issue.

  • Issue and Investigation

I had been having this same issue with one of my humanoid models in Scene view. I imported the model from Blender with an origin of (0,0,0). I added the model to my prefab and then went to add modular components to the prefab (e.g. hair, eyeballs, etc.), but found that I couldn’t zoom into the model’s face. In fact, I couldn’t zoom in any closer than 3 or so meters out from the model without the model being clipped out of view (interesting thing, was that the modular components DIDN’T get clipped out (i.e. the hair would stay in view, but the model disappeared). This became extremely painful because I couldn’t zoom in to precisely place the modular components with any accuracy.

With further tinkering, I noticed that the issue was much worse when I was attempting to zoom in on the characters upper portions (i.e. I could zoom into the feet with extreme detail, but if I panned the view such that the feet left the view, the model immediately disappeared; I had to be equally zoomed out as I was panned up). A lot of other suggestions for this are to click [F] which “Focuses” on the model, and I noticed that it ALWAYS focused on the feet of my model. I later figured out that it was focusing on the Origin of my model and furthermore, I figured out that the clipping of the model was occurring based on the origin leaving my scene view.

This let me know that the issue is specifically due to incorrect clipping settings on my model. This lead me to the inspector of the model itself, where I found, on the “Skinned Mesh Renderer” of my model, a set of properties called “Bounds” which has a pair of Vector3 called “Center” and “Extent”, both of which were 0’d out.

I’ve determined that these properties define the clipping bounds of the model. Them being 0’d out meant that if the origin (which was set as center) as well as the surrounding bounds (also 0, 0, 0) left the Scene ViewPort, then the model was clipped out.

  • SOLUTION

By properly setting the Center and Bounds properties on the Skinned Mesh Renderer component of my model such that the bounds outlines my entire model, I am now able to greatly zoom into my model’s face without the model clipping out.