Need A workaround for two Unity bugs

I get two errors whenever I import a rigged model from Blender:

!IsFinite(outDistanceAlongView) UnityEditor.Handles:Internal_DrawCamera(Camera, Int32) UnityEditor.Handles:Internal_DrawCamera(Camera, Int32) UnityEditor.Handles:DrawCamera(Rect, Camera, Int32) UnityEditor.SceneView:OnGUI() System.Reflection.MonoMethod:InternalInvoke(Object, Object[]) System.Reflection.MonoMethod:InternalInvoke(Object, Object[]) System.Reflection.MonoMethod:Invoke(Object, BindingFlags, Binder, Object[], CultureInfo) System.Reflection.MethodBase:Invoke(Object, Object[]) UnityEditor.HostView:Invoke(String) UnityEditor.DockArea:OnGUI()

[....\Runtime\Camera\RetainedRenderqueue.cpp line 335]

!slot->GetLocalAABB().IsValid() UnityEditor.Handles:Internal_DrawCamera(Camera, Int32) UnityEditor.Handles:Internal_DrawCamera(Camera, Int32) UnityEditor.Handles:DrawCamera(Rect, Camera, Int32) UnityEditor.SceneView:OnGUI() System.Reflection.MonoMethod:InternalInvoke(Object, Object[]) System.Reflection.MonoMethod:InternalInvoke(Object, Object[]) System.Reflection.MonoMethod:Invoke(Object, BindingFlags, Binder, Object[], CultureInfo) System.Reflection.MethodBase:Invoke(Object, Object[]) UnityEditor.HostView:Invoke(String) UnityEditor.DockArea:OnGUI()

[....\Runtime\Camera\Culler.cpp line 60]

Yes, I've sent a bug report, but this doesn't directly alleviate the problem. I still need a way to keep those two errors from popping up, as it's literally slicing my game's FPS in half!

These errors generally mean that one of the objects don't have valid bounds. While I agree that this is definitely a bug we should fixed (if we haven't in 3.0), to work around it for now, you should try finding out which object is causing it. Make a copy of the scene and take objects out until you no longer see the object. In the end you will probably find a mesh which has either zero vertices, or which has vertices with invalid numbers in it. Try to edit those meshes in Blender to see if you can make it go away.

Theres a similar bug with particle which you can read about here.

From reading through what you're doing and the actual error messages, it could be that the scale of your scene is going beyond the regular bounds of the scene, or it could be too small for Unity to deal with. Check your scale settings, and make sure they are something reasonable compared with other objects you have successfully imported from Blender.

i got the same error messages tonight & after a hunt around i realized it comes from setting the thing “static” in the inspector window. uncheck static for the object(s) & it goes away.

worked for me anyway so thought i’d share :slight_smile: