Need help with error ive never seen before: "MethodAccessException: Requires team license"

Recently, I updated one of my older projects (Made in Unity 5.6) to a current version of Unity (Unity 2019.2.0f1). But, after downloading the new version and starting up my project I ran into a really weird error. I can still play my game, edit the scene hierarchy and mostly use the editor without noticing anything weird, but anytime I try to view something from my project files in the Unity inspector, my console gets flooded with errors saying “MethodAccessException: Requires team license”, and it doesnt display anything in the inspector.

Most of the errors are only sent once, but some errors are continuously sent to the console which has made debugging impossible. I have tried reinstalling Unity, deleting my project’s Library folder, and even deleting the registry files that Unity uses, but the error still persists. If anyone knows any solutions for fixing these errors, please help me out!

Full Errors:
https://pastebin.com/ThBbDqkh

Hey just thought I’d update this with a fix that I found if anyone else ever runs into this issue. For me, the issue was stemming from the Unity Github asset that I had downloaded from the asset store before I updated my Unity. Deleting it from my project resolved the errors being sent to my console. If you are getting this error, consider deleting any plugins or assets that you have recently added to your game.

ANOTHER QUICK FIX:

I‘ve got the same „Requires Team License“ error especially in the inspector.
For me it worked by simply removing the „Version Control“ package in the Package Manager inside the Unity Editor (v: 2019.4.39f1).

Searched so long for a fix for this problem, interesting how easy the fix actually was. Hope it works for anyone of u having the same issue.

Okay ANOTHER SOLUTION EVERYONE!! @greenboy19 INCASE YOU GUYS GET THE SAME ERROR: I fixed it myself, but this problem plagued me for 3 days- on my own birthday!! I was scrolling through google links and tired from all the searching; searching on youtube- google- discord servers- unity support. Deleting my unity account- making a new one- uninstalling unity fully and reinstalling it. The idea is that if youre starting off on unity; whether youre using it to make a model on VRChat like me or a game, your license activation files probably got corrupted. So what you want to do is create a manual license using the command line method shown here! Make sure you guys follow the instructions from the Unity support article exactly step by step. Or I cant guarantee its going to work, there are no shortcuts!! Make sure to open unity after using the Editor of your choices EXE File. https://support.unity.com/hc/en-us/articles/5429281306132-My-license-isn-t-activating-

So here’s what I found from my limited testing over the last week.
The error appears in version 2019.4.31f1 (which I am using as it is the “suggested” version for the VRC SDK Avatars 3.0)
It also appears in version 2019.4.40f1 (LTS) but not in 2020.3.40f1 (LTS) or 2021.3.11f1 (LTS) unfortunately the VRC SDK does not work in either of these working versions.
It is not caused by any assets added to the project, because the same error appears in entirely empty projects with nothing imported.
On a whim, I tried installing Unity on another computer, and it worked. No errors, everything works as intended. Logged in on the same account as my main computer, so the issue is not with the license.
This is not an ideal solution for me, as the “another computer” is my old laptop, still running Windows 8. Not exactly the fastest computer in existence.

[EDIT] Bignk05, you have just saved me hours of work. That fixed it where nothing else did. The Version Control package is the culprit.