Net Standard core 2.0 library states .NET 4.x

I’m attempting to create a basic library for my Unity project. I have built a basic .Net Standard 2.0 class library, this is just a standalone solution with one csporj. I built the project into a dll and dragged it into my Unity project which is version 2019.3.7f1. Looking at the properties of the dll you can see this



“Assembly info: Targets .NET 4.x”

Why does it state this? Shouldn’t it show .NET Standard 2.0
Here is my project settings



My project still runs and plays, just wanted to check this is “correct”, I don’t want to put time into my library project if I am building it incorrectly for Unity. Here is my project settings


alt text

I just checked one of my .NET Standard 2.0 libraries and Unity shows the same Assembly info: Targets .NET 4.x to it:
170860-screenshot-4.png

I verified my library assembly with ILDASM to make sure that is a valid .NET Standard 2.0 library:
170862-screenshot-5.png

I already used this library on Unity projects with Api Compability Level set to .NET Standard 2.0 with success, inclusive released on Google Play. So, I think you don’t need to worry about that.

Thanks for the update and quick reply. I’ll be sure to keep an eye on this thread.
MCDVOICE