NetworkClient.connect() not working since last update

Hi, I dont know why, I dont change nothing, and I never was problem with function, but now,

NetwoorkClient.Connet (“111.11.111.11”, 12345) never connect.

All others functions reltaded are working fine, but this line its full broken for me.

// Tipical code I was use since months

public NetworkClient myConn;

    public void ConnectToIP()
    {
        myConn = new NetworkClient();

        myConn.RegisterHandler(MsgType.Connect, Connected);
        myConn.RegisterHandler(MyCustomMSG, MyCustomFunction);

        ClientScene.RegisterPrefab(prefab);

        myConn.Connect("99.123.123.132", 12345);
    }

    public void Connected (NetworkMessage msg)
    {
        Debug.Log("Connected");
        // DO things
    }

Ok all easy and basic, Why Now its imposible to connect for me? I tried on some PCs and tested all related functions, user with NetworkServer listening open ports, and checked if are active. But the only problem, myConn.Connect(); Never connects, seems like if the code are empty.

Ok the best thing, testing with Debug strings I was trying this code

 private void Update()
    {
          print(NetworkServer.active);
    
         if(myConn != null)
        {
              print(" Im connected ??? " + myConn.isConnected);
        }
    }

Results : Not connected, ok, all right

I placed the last line to test.

private void Update()
    {
        print(NetworkServer.active);
        if(myConn != null)
        {
            print(" Im connected ??? " + myConn.isConnected);
        }
        print(NetworkClient.active); //////////////////////////////// ONLY THIS LINE
    }

Results?? 1 false result and then, connected with server, and Handler Connected with Degun.Log(“Connected”) writed on console

!!! Is the most no sense case I never see

Ok, coincidence… try again, same result, try again, same, try on other PC shared the build to people and same result.

Try the same code on new version of unity, not working. Return to old version not working again.

I Think, Functions can be called inside of prints and print true or false, but, NetworckClient.active its only to read info !!! Im crazy i dont understand nothing, , and I dont found anybody on forums with the same problem, everybody are fine.

Please, kill me…

I have the same issue since 2017.2

Well, Im sorry, but finally the problem was me :slight_smile: Only me and top user have the problem, this finally should be expected like the fault its on any problem us;

I dont know Why, but my router made changes on all local IP adress of all connected devices. Then all open ports I was configured looking for an incorrect adress making that server cant recive any incoming connection.

Fix the correct adress again on my router fix my problem.