Networking Version Mismatch error in Unity 5.6

Hey, after upgrading to Unity 5.6 i’m getting

 ClientDisconnected due to error: VersionMismatch

when trying to establish connection.
It only happens when I use client built with unity 5.6
(client 5.6/server 5.6 fails, but client 5.5/server 5.6 works fine).
Any ideas what kind of “version” this is about?

Are you sure it is your 5.6 client to 5.6 server failing instead of 5.5 client to 5.6 server? You’re encountering a network protocol version mismatch error, which I would expect if you are building client and server with different Unity editor versions, especially with the significant networking changes in 5.6.